r3wp [groups: 83 posts: 189283]
  • Home
  • Script library
  • AltME Archive
  • Mailing list
  • Articles Index
  • Site search
 

World: r3wp

[!REBOL3]

Pekr
11-Jan-2011
[6845x2]
Carl should comment. The question is, if you can get his attention 
- he is not much active in R3 user-land last 2-3 months ....
I would suggest you going with faces? then, we can always change, 
while in alpha mode ....
Ladislav
11-Jan-2011
[6847x3]
modified? Does it stand for the logic value, returning the true or 
false, or does it stand for the return of modification date? How 
should user know?

 - the function name rarely suffices to inform the user what exactly 
 the function does. In such a case it is the task for the doc string 
 to inform the user, or, we should use two words, as described in 
 the doc.
(even the doc string may be insufficient, and an online documentation 
should be consulted in some cases)
As far as the 'faces? vs. 'get-faces names are considered, they both 
adhere to the function naming convention. The only advantage of the 
'faces? name is, that it is just one-word, so it is "more in the 
line" with the function naming convention in my opinion)
Pekr
11-Jan-2011
[6850]
just a note - actually, it was not get-faces, but faces-of, IIRC?
Ladislav
11-Jan-2011
[6851]
'get-faces was your original proposal, AFAIR. Nevertheless, the 'faces-of 
name, which looked as preferred by the majority, is clearly violating 
the above function naming convention.
Oldes
11-Jan-2011
[6852]
for me it's more important how it looks in code.. so it's for example:
	foreach face faces? window [ ... ]
vs.
	foreach face faces-of window [ ... ]
Ladislav
11-Jan-2011
[6853x3]
And, in fact, it is a C naming convention, except for the fact, that 
in C it would need to be faces_of
One of the possible solutions is to just add the *-of as an alternative 
convention, and have the option to choose. The only problem remaining 
is, that it uses two words instead of one.
What is interesting (and surprising me), is the fact, that, not reading/remembering 
the REBOL function naming convention, lots of people immediately 
were able to define any kinds of "ad hoc rules" which (purportedly) 
were in effect in Rebol for function naming, and used that as their 
argument why their preferred name was in accordance with the REBOL 
function naming convention.
Andreas
11-Jan-2011
[6856]
I always had the impression that the "word names" section in the 
style guide is more descriptive than prescriptive. To that effect, 
I'm very much in favour of documenting *-of as an alternate convention.
Pekr
11-Jan-2011
[6857]
We should state that in above ticket as na alternative, if already 
not there ...
Kaj
11-Jan-2011
[6858x3]
Sorry, but it makes no sense to interpret this optional convention 
strictly. If we do, we also have to do the following renames:
about? abs? absolute? alias? arccosine? arcsine? arctangent? as-binar? 
as-pair? as-string?
I hope you can find the rest yourself for b-z
Ladislav
11-Jan-2011
[6861]
about is not a noun as far as I know, abs is not a noun as well...
Kaj
11-Jan-2011
[6862]
Your previous argument, as I remember it, was that this convention 
applies to properties
Ladislav
11-Jan-2011
[6863]
no, my argument was, that we have a convention for naming functions
Kaj
11-Jan-2011
[6864x2]
Yes, a convention, not a low cut out in stone, and we already established 
that only a select subset of standard words conforms to it
a law
Ladislav
11-Jan-2011
[6866]
so what, your argument does not apply anyway, except for some nouns 
naming math operations
Kaj
11-Jan-2011
[6867]
So, it's not consistent
Ladislav
11-Jan-2011
[6868]
yes, that is what I pointed at using words-of, etc. as examples. 
Your examples do not apply, since they are either nouns naming math 
operations or not nouns at all.
Kaj
11-Jan-2011
[6869x2]
Every variable name is a noun, in principle. Do we have to use question 
marks on all variables?
Why would only math operations be excempt from this law?
Ladislav
11-Jan-2011
[6871]
it is hard to use a logic argument when you refuse to discern nouns 
from other words, but, in that case, you are unable to stick to the 
function naming convention anyway, and I don't know what do you want 
to discuss
Kaj
11-Jan-2011
[6872]
How am I refusing to discern nouns from other words?
Ladislav
11-Jan-2011
[6873]
Every variable name is a noun, in principle.
Kaj
11-Jan-2011
[6874x2]
How is that not true?
I mean variable in the sense of traditional programming languages
Ladislav
11-Jan-2011
[6876]
we do not have "variable names" we have words
Kaj
11-Jan-2011
[6877x3]
See above
foreach [cat? dog?] [1 2 3 4] [fight cat? dog?]
This would be the result of your rule
Ladislav
11-Jan-2011
[6880x2]
this would be the result?
*very unlikely*
Kaj
11-Jan-2011
[6882]
Cats and dogs are nouns
Ladislav
11-Jan-2011
[6883]
so what
Kaj
11-Jan-2011
[6884]
You said your rule applies to nouns
Ladislav
11-Jan-2011
[6885]
not my rule, please read the rule, I am not the one who wrote/defined 
it, I am only using it
Kaj
11-Jan-2011
[6886]
No, you are interpreting it for us, while many of us have a different 
interpretation
Steeve
11-Jan-2011
[6887]
To begin with, I never liked faces-of or faces? proposals.
faces
 should be enough.
Plural means that it returns a serie of faces.

It may be a static list (reference) or a constructed one (function), 
I don't bother.
The context give all the hints I need.
*-of is a lame and useless convention.

Because a property or a method is always the relative "-of" something 
else .
Ladislav
11-Jan-2011
[6888]
your interpretation is *quite exceptional*, how could I be able to 
get to the same one?
Kaj
11-Jan-2011
[6889x2]
I agree, faces should be enough, unless that is likely to be used 
for something else in the same context, in which case you can switch 
to a convention for a more elaborate name
Ladislav, I'm just asking you how your interpretation works, and 
you said it applies to nouns
Ladislav
11-Jan-2011
[6891]
Are you saying, that you are unable to read the rule, and see, that 
it applies to nouns?
Kaj
11-Jan-2011
[6892]
Are you unable to see that this rule has not been applied to most 
REBOL words?
Ladislav
11-Jan-2011
[6893]
Because it is a REBOL function naming convention, which you happen 
to not know, since you did not read it yet
Kaj
11-Jan-2011
[6894]
I did read it